通达信macd公式教程,通达信手机版缠论指标大全

内容导航:
  • 通达信macd面积公式怎么导入
  • 求高编写一个通达信MACD公式
  • 通达信指标公式编写教程[完整版]
  • 请老师编写一个macd的选股公式通达信的谢谢
  • 求通达信缠论精确笔主图画线公式
  • 谁有通达信软件里的缠论笔结构的指标
  • Q1:通达信macd面积公式怎么导入

    {MACD面积}

    DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

    DEA:EMA(DIF,9);

    MACD:(DIF-DEA)*2,COLORSTICK;

    JC:=DEA-DIF;


    绿柱面积:IF(MACD<0,SUM(0-MACD,BARSLAST(JC<0)),0),NODRAW,COLOR00FF00;

    红柱面积:IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0),NODRAW,COLOR00FFFF;

    A1:=IF(MACD<0,HHV(绿柱面积,BARSLAST(JC<0)),0);

    A2:=IF(MACD>0,HHV(红柱面积,BARSLAST(JC>0)),0);

    DRAWNUMBER(CROSS(DIF,DEA),0,REF(A1,1)),COLOR00FF00;

    DRAWNUMBER(CROSS(DEA,DIF),0,REF(A2,1)),COLOR00FFFF;

    LM:=REF(绿柱面积,BARSLAST(CROSS(DIF,DEA))+1);

    HM:=REF(红柱面积,BARSLAST(CROSS(DEA,DIF))+1);

    转强:CROSS(红柱面积,LM),NODRAW,COLORFFFF00;

    转弱:CROSS(绿柱面积,HM),NODRAW,COLOR00FF00;

    DRAWICON(转强,DEA,5);

    DRAWICON(转弱,DEA,6);


    Q2:求高编写一个通达信MACD公式

    XG: COUNT(CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0,21)=2 AND CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0 AND(REF(C,BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0,1))+1) + REF(C,BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA) AND MACD.DEA<0,1))+1+1))/2> (C+REF(C,1))/2;

    Q3:通达信指标公式编写教程[完整版]

    兔年到,好运到。幸福在你绕,健康对你把手招,平安对你露微笑,吉星把你照,财神牵着你在跑,所有好事都来到,祝你在新的一年里幸福乐逍遥!

    Q4:请老师编写一个macd的选股公式通达信的谢谢

    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    MACD:=2*(DIFF-DEA);
    SX:=BARSLAST(CROSS(DEA,DIFF))+1;
    JX:=BARSLAST(CROSS(DIFF,DEA))+1;
    T1:=IF(JX=1 AND DIFF>REF(DIFF,REF(JX,1)+1),1,0);
    T2:=IF(JX=1 AND LLV(DIFF,SX)>REF(LLV(DIFF,SX),SX),1,0);
    XG:T1 OR T2;

    Q5:求通达信缠论精确笔主图画线公式

    {精确缠论中枢公式}
     
    {N1:1,100,10;N2:1,100,10;DISP:=1,3,2};
    n1:=10;
    n2:=10;
    DISP:=2;
    N1:=10;N2:=10;DISP:=2;
    K:=IF(PERIOD=5,1,{日}
    IF(PERIOD=6,1,{周}
    IF(PERIOD=7,1,{月}
    IF(PERIOD=8,1,{多分钟}
    IF(PERIOD=9,1,{多日}
    IF(PERIOD=10,1,{季}
    IF(PERIOD=11,2,{年}
    IF(PERIOD=4,1,{60F}
    IF(PERIOD=3,1,{30F}
    IF(PERIOD=2,1,{15F}
    IF(PERIOD=1,1{5F},1{1F})))))))))))/10;
    P1:=PEAK(1,K*N1,1);
    P2:=PEAK(1,K*N1,2);
    WP1:=PEAKBARS(1,K*N1,1);
    WP2:=PEAKBARS(1,K*N1,2);
    T1:=TROUGH(2,K*N2,1);
    T2:=TROUGH(2,K*N2,2);
    WT1:=TROUGHBARS(2,K*N2,1);
    WT2:=TROUGHBARS(2,K*N2,2);
    TJ1:=P1>T1 AND P2>T2 ;
    ZD:=MAX(T1,T2);
    ZG:=MIN(P1,P2);
    LL:=MIN(T1,T2);
    HH:=MAX(P1,P2);
    TJ2:=FILTER(ZG>ZD,2);
    TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
    TJ4:=TJ1&&TJ2&&NOT(TJ3);
    TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
    TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
    ZSD:=IF(TJ8,ZD,DRAWNULL);
    ZSG:=IF(TJ8,ZG,DRAWNULL);
    ZSH:=IF(TJ8,HH,DRAWNULL);
    ZSL:=IF(TJ8,LL,DRAWNULL);
    STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
    STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
    DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;
    中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;
    中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;
    {中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;
    中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;}
    趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;
    趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;
    局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
    局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
    局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
    局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
    局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
    局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
    缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
    距前高天:=BARSLAST(局部高点预选C=1);
    距前低天:=BARSLAST(局部低点预选C=-1);
    小值周期:=LOWRANGE(L);
    大值周期:=TOPRANGE(H);
    低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
    低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
    低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
    预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
    判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
    高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
    高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
    高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
    预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
    判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
    低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
    低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);
    低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
    距前高天A:=BARSLAST(高保留=1);
    距前低天A:=BARSLAST(低保留=-1);
    预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
    判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
    高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
    高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
    高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
    预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
    判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
    低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
    低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
    低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
    距前高天YA:=BARSLAST(高保留X=1);
    距前低天YA:=BARSLAST(低保留X=-1);
    预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
    判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
    高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
    高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);
    高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
    预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
    判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
    低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
    低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);
    低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
    AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
    极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
    局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;
    DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORLIRED;
    DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORYELLOW;
    DD1:=BARSLAST(ABS(极点保留)!=1);{
    DRAWTEXT(极点保留=1,局部极点,'卖'),COLORGREEN;
    DRAWTEXT(极点保留=-1,局部极点,'买'),COLORRED;}
    MA5:MA(CLOSE,5),COLORFF00FF,LINETHICK2;判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORWHITE,LINETHICK2;

    Q6:谁有通达信软件里的缠论笔结构的指标

    分笔分段是掌握缠论的关键所在,划笔和划线段,其本质是通过均匀的分解走势去感应走势及其变动,大量的划笔划线段,是获得盘感的重要途径。你现在要省了这个环节,如同省了1、2楼直接要3楼一样,如何可得?在别人的1、2楼上盖3楼,又如何是你的3楼?何况,公式划出来的笔段,你敢信么?跪求!?不是不行,只是莫再向外,向别人,而应该向内,向自己。

    上一篇:上一篇:建信优选基金今日净值
    下一篇:下一篇:恒生综合小型股指数
    • 评论列表

    发表评论: